ARP/wARP 7.6

Status 20160324

autoSHARP uses ARP/wARP for automatic model building at later stages (after initially using BUCCANEER) as long as the resolution is high enough.

Version 7.6 of ARP/wARP as distributed and installed with CCP4 7.0 might reference /usr/bin/tcsh in its scripts if this was encountered during installation - changing /bin/csh to the first occurence of tcsh in the users PATH. This can cause problems in centralised, heterogeneous installations since e.g. at least CentOS version 5 and 6 will only have /bin/tcsh and therefore fail running those scripts.

This version of autoSHARP will try and detect this condition and (after giving an adequate warning message) continue to use BUCCANEER for model building. However, this might result in a different quality of the final model compared to using previous versions of CCP4 and/or ARP/wARP - and also depending on the operating system the program is run on, i.e. if it contains /usr/bin/tcsh or not.

One solution is to install on a system where /bin/tcs is found first in the PATH ("which tcsh") or to exchange /usr/bin/tcsh by /bin/tcsh in the ARP/wARP scripts.

The ARP/wARP developers are notified of this issue.

Version reported by release

Status 20160324

The vesion reported by the software will be

It is only the version number that is trailing by one: the underlying softwre/functionality is all up-to-date.