[sharp-discuss] some issues with the installation for AutoSHARP 2.8

Clemens Vonrhein vonrhein at globalphasing.com
Tue Jan 19 19:53:06 CET 2016

Dear Azmiri,

On Tue, Jan 19, 2016 at 01:30:17PM -0500, Azmiri Sultana wrote:
> I tried to install the AUTOSHARP according to the QUICK installation
> instruction I found on the Global Phasing webpage:
> https://www.globalphasing.com/sharp/installation/index.html#quick
> <https://www.globalphasing.com/sharp/installation/index.html#quick>.. I
> had a few questions about the correctness of the installation..
> Everything seemed to be normal.. their was no error when it unpacked
> and installed the Sharp which I watched on the terminal…


> Now when I checked the status of the software on the server(with the
> check_server command) it tells me that the sushi server is running
> on iMac:8080.. I tried to put in http://imac:8080
> <http://imac:8080/> on firefox, chrome and safari and it says it
> can’t find the webpage.. Is there something I am missing here?

Macs are sometimes a bit funny in not recognising their own host name -
so try with


Remember to re-run the /Users/Azmiri/sharp-2.8/start.sh script after a
reboot of your Mac computer. In a terminal just type

> Also, I wanted to run the SHARP from CCP4i… So I input the two commands that was suggested.. 
> source /Users/Azmiri/Applications/ccp4-6.5/bin/ccp4.setup-sh

What shell are you running? If it is tcsh/csh you would use

  source /Users/Azmiri/Applications/ccp4-6.5/bin/ccp4.setup-csh

while with sh/bash/zsh it would be

  . /Users/Azmiri/Applications/ccp4-6.5/bin/ccp4.setup-sh

> export BDG_home=/Users/Azmiri/sharp-2.8

This is the syntax for sh/bash - so I guess you are running bash (see
output of "echo $SHELL").

> (It complained about the BDG_home while I tried to open the Autoharp from CCP4i)
> I also included these two lines in my bashrc file… 

Yes, you could do this.

> After that, I can only see the Autoharp button activated when I
> start CCP4i from the terminal…But it’s not working when I open CCP4i
> from the applications folder with the icon..

Correct: that application bundle ignores your ~/.bashrc file and
therefore doesn't know about that environment. Somehow you need to
tell it about the BDG_home (or better with latest SHARP/autoSHARP and
CCP4: SHARP_home) variable. You could add that setting to the end of
the official CCP4 setup file(s)
/Users/Azmiri/Applications/ccp4-6.5/bin/ccp4.setup-{sh,csh} for

> Also, in the interface command window, for a SAD experiment for
> example, it only gives me the option of SHELXD from the drag and
> drop menu (attached figure), Should there be another option like
> “SHARP” in the menu?….

No: SHELXD is the program to use for heavy atom detection while SHARP
is the actual heavy atom parameter refinement and phasing program.

> Therefore, I am thinking now that even though I have seen it
> installed and I can at least open the interface in ccp4i but it
> might not be properly installed or perhaps I am missing any last
> steps?… Could you please advise me how I should check that it is
> properly installed?

It sounds as if everything is installed correctly. If you feel half
confident with the command line, you could also run

  . /Users/Azmiri/sharp-2.8/
  run_autoSHARP.sh -h

and see the help message for the command-line interface to autoSHARP.

> Also, I wanted to install the Autosharp through CCP4i so that I can
> have autosharp working from the Applications/ccp4i as well. So, I
> tried to use the system administration option but I didn’t find the
> CCP4i-autosharp.tar.gz file anywhere in the folder I downloaded… So,
> if I want to have sharp installed through system administration,
> where will I get that tar.gz file?

This path is only for installing CCP4i interface packages into the
existing CCP4i - not for installing actual program packages (like
SHARP/autoSHARP). Since recent CCP4 versions already include autoSHARP
there is no need for that - and it would not do what you expect anyway
(namely installing the actual SHARP/autoSHARP software).
> I would be very thankful if you could give me some guidelines about
> how I can run the program on the server and if my ccp4i installation
> is correct so far or I need to do some more steps to get it fixed..

I think you basically have everything installed and running - just
need to get used to a few Mac quirks (that we should address and
try to remove as far as possible from our software ... yes).




* Clemens Vonrhein, Ph.D.     vonrhein AT GlobalPhasing DOT com
*  Global Phasing Ltd.
*  Sheraton House, Castle Park 
*  Cambridge CB3 0AX, UK
* BUSTER Development Group      (http://www.globalphasing.com)

More information about the sharp-discuss mailing list